viernes, 3 de febrero de 2012

Resolver Error "libavcodec52-0.7.8-49.fc16.i686 necesita libvpx.so"

 Resolver Error "libavcodec52-0.7.8-49.fc16.i686 necesita libvpx.so.0 : Exito - transacción vacía"

El dia miercoles me encontre con este lindo error al querer actualizar fedora. Hoy lunes 06 de febrero 2012 Aun no han lanzado una actualización que lo corrija, si ha llegado a este post, pues existe la posibilidad de solucionarlo mientras se corrije el problema en los repositorios.

¿A que se debe esto?

Esto se debe a la incompatibilidad entre  rpmfusion y repositorios de Fedora. Hay que fijarse en breve, mientras lanzan una nueva actualización.

Este es el bug, reportado: https://bugzilla.redhat.com/show_bug.cgi?id=786842


Este error afecta a:

    ffmpeg-0.8.9-1.fc16.i686 de rpmfusion-free-updates
    ffmpeg-libs-0.8.9-1.fc16.i686 de rpmfusion-free-updates
    firefox-10.0-1.fc16.i686 de updates
    gstreamer-plugins-bad-free-0.10.22-2.fc16.2.i686 de updates
    gstreamer-plugins-bad-free-extras-0.10.22-2.fc16.2.i686 de updates
    libvpx-1.0.0-1.fc16.i686 de updates
    xulrunner-10.0-1.fc16.i686 de updates




Y todo programa que utilice libvpx



La forma de solucionarlo es: 

sudo rpm -e --nodeps gstreamer-plugins-bad-free libvpx 


sudo yum update -y 






Otras formas


Ignorando paquetes que den conflicto

Esto no lo arregla, simplemente ignora las actualizaciones que presenten conflicto con este error, y no te dejara instalar la nueva version de Firefox 10 :(


Desde una terminal
su (tu pasword de root)


yum update --skip-broken

Reacciones:

1 comentario:

Si comentas te pedimos por favor respeto y críticas constructivas referentes al título del articulo. Cualquier comentario para desviar el tema, spam o trolleo no será permitido. Gracias por comentar.